Connexion
Vous n'avez pas encore de compte personnel ? Vous devriez en créer un. Une fois enregistré vous aurez certains avantages, comme pouvoir modifier l'aspect du site, ou poster des commentaires signés...
Support
Activité du Site

Pages vues depuis 06/01/2019 : 4 005 516

  • Nb. de membres 361
  • Nb. d'articles 2 612
  • Nb. de forums 24
  • Nb. de sujets 13
  • Nb. de critiques 0

Top 10  Statistiques

Index du forum »»  Logiciel »» OWB et démarrage

OWB et démarrage#266

5Contributeur(s)
daffPapiosaurBrumigarmsFab
1 Modérateur(s)
Papiosaur
daff dafficon_post
La version 1.3 d'OWB se lance en 2-3 secondes maximum alors que la version 1.4 prend 9 secondes. Est-ce que ce phénomène est également présent chez vous ? Serais-ce dû Ã la gestion/recherche des polices de caractères ?

Message édité par : Papiosaur / 16-09-2009 20:56

Papiosaur Papiosauricon_post
Salut Daff,

Je crois que ça vient en effet du scan du ou des répertoires contenant des polices truetype.
Brumiga Brumigaicon_post
Bonsoir,

Ici, sur mon peg2 g4, owb 1.4 se lance en 3 secondes. Je l'ai lancé après snoopdos pour voir ce qui le ralentit et ce serait history.db qu'il recherche, écrit et efface de nombreuses fois. Mon fichier cookies est quelque peu volumineux, 220 ko, mais ça ne semble pas géner owb.

Je viens d'effacer les fichiers cookies et history.db mais ça ne change rien au temps, 3 secondes ici, que met owb à se lancer.

Brumiga

Message édité par : Brumiga / 16-09-2009 22:09

rms rmsicon_post
Je pense c'est à cause l'exe est compressé, OWB 1.4 = 10 MB, OWB 1.3 = 35 MB. Selon Fab la version non compressé ce lance plus rapidement.

Christoph
Fab Fabicon_post
Daff,

Pour mettre 9s, il faudrait que ta machine soit vraiment très lente: l'exe fourni avec MorphOS2.3 est en effet compressé (comme tous les autres exécutables de l'OS), mais la décompression ne prend pas plus d'une seconde sur un Peg2/G4.

Je pense que même un efika fait mieux que ça. :)

Brumiga,
Le fichier cookie n'a pas d'incidence sur le démarrage. Le fichier history, il faut voir, mais à moins d'avoir quelques centaines de milliers d'entrées, j'en doute.

Papiosaur,
Le scan des fontes n'a rien à voir, puisque l'objectif de la création du cache de fontes est justement de ne le faire qu'une fois. Par ailleurs, on le voit clairement quand les fontes sont scannées. :)


Message édité par : Fab / 17-09-2009 20:43

Papiosaur Papiosauricon_post
Merci Fab pour ces éclaircissements ;)

Daff, peut-être une carte USB2 PCI qui ralenti le système ?

daff dafficon_post
Après réinstallation complète, le problème a été localisé : il s'agissait du fichier de cookies (750 ko).

Le lancement est à présent bien plus rapide.

Papiosaur : la carte USB2 ne ralenti que les Pegasos I.

Merci à tous pour vos réponses.