Connexion
Vous n'avez pas encore de compte personnel ? Vous devriez en créer un. Une fois enregistré vous aurez certains avantages, comme pouvoir modifier l'aspect du site, ou poster des commentaires signés...
Activité du Site

Pages vues depuis 06/01/2019 : 557 224

  • Nb. de membres 352
  • Nb. d'articles 2 556
  • Nb. de forums 24
  • Nb. de sujets 13
  • Nb. de critiques 0

Top 10  Statistiques

Index du forum »»  Logiciel »» Mise à jour de la base de Grunch - Amirc 3.8

Mise à jour de la base de Grunch - Amirc 3.8#2216

5Contributeur(s)
nerumoPapiosaurK-LBrumigaJedi
1 Modérateur(s)
Papiosaur
nerumo nerumoicon_post
Salut,

Amirc est passé à la version 3.8 et Grunch me dit qu'il est dépassé.
Il indique une version 3.6.2 en ligne.

En local Grunch ne montre pas de version, j'ai installé la 3.8



Est-ce que c'est un problème avec Grunch ?
Papiosaur Papiosauricon_post
Tu as installé AmIRC à la mano donc ?

Essaye de faire la mise à jour via Grunch pour voir si c'est possible.
K-L K-Licon_post
Justement, la version 3.8 n'est pas proposée, uniquement l'ancienne 3.6.2. Et comme Grunch ne connaît pas la 3.8, il la considère comme étant une version obsolète et veut réinstaller la dernière version officielle connue dans sa base de données.
Papiosaur Papiosauricon_post
C'est bizarre que Grunch ne la propose pas car la dernière version est bien sur le serveur dédié...
nerumo nerumoicon_post
Merci pour les infos,
Alors je viens de le désinstaller par Grunch, puis réinstaller par Grunch aussi.
C'est bien la version 3.6.2 qu'il installe, et cette fois il trouve bien le numéro de version 3.6.2

c'est donc la 3.6.2 qui est sur le serveur,
et la 3.8 que j'ai téléchargé ne comporte pas de numéro de version.

C'est pas grave

Edit :
par contre je vienbs de voir que la version 3.8 comporte un répertoire libs avec vapor_toolkit.library
je ne sais pas si ça a un rapport.
La 3.6.2 n'a pas cette library et dans mon installation de Morphos+Chrysalis elle n'y est nulle part
 Message édité par : nerumo / 14-06-2021 21:20
Papiosaur Papiosauricon_post
L'archive de la 3.8 est sur :
http://www.biclodon.com/software/amirc/amirc_38_morphos.lha

Dans la base de donnée de Grunch il y a écrit :
http://biclodon.com/software/amirc/amirc_{VERSION}{REVISION}{BUILD}_morphos.lha

Il manque peut-être le chiffre 0 correspondant au build...
Brumiga Brumigaicon_post
Je pense qu'Henes, auteur d'amirc, devrait faire un effort et mettre à jour sa base de donnée pour grunch. Ainsi on pourrait télécharger la(les) dernière(s) version(s) de son(ses) programme(s). D'autres codeurs actifs et ayant une base de donnée de leurs programmes pour grunch font l'effort de la maintenir à jour, tels jpv ou igracki. Qu'Henes fasse un effort de son côté !

Brumiga
Papiosaur Papiosauricon_post
Brumiga, on va essayé de garder la bonne humeur dans ce forum et ne pas s'énerver contre des développeurs hein ?

Je lui est envoyé un message hier sur AmIRC pour lui parler du soucis.

Patientons un peu...

il reste l'installation/mise à jour à la mano qui n'est pas impossible à faire non plus...

Je rappelle qu'on a tous une vie à côté de MorphOS...

La respiration en cohérence cardiaque donne de bons résultats sur notre corps et notre esprit, namasté ;-)
Papiosaur Papiosauricon_post
ça y est, ça marche, la base de donnée de Grunch a été mise à jour par Geit je pense et permet de mettre à jour ou d'installer AmIRC 3.8.

La configuration d'AmIRC étant dans la base de donnée de Grunch et non de celle d'Henes, j'en conclus qu'il ne pouvait rien faire à son niveau.

Donc soutenons nos développeurs et non l'inverse...
nerumo nerumoicon_post
La version 3.8 est en effet maintenant visible par Grunch sur le site,
mais le fichier local une fois installé ne contient pas de chaine de version.
Donc Grunch indique toujours qu'il est dépassé